現在位置: ホーム / セキュリティ ブログ / curlの脆弱性 ( CVE-2017-2629 )

curlの脆弱性 ( CVE-2017-2629 )

2/22に、curl / libcurlに関しての脆弱性情報 ( CVE-2017-2629 )が出ています。今回は、この脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面です。

2/22に、curl / libcurlに関しての脆弱性情報 ( CVE-2017-2629 )が出ています。今回は、この脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。



Priority

Moderate/Midium

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • CVE-2017-2629
    • curlの"SSL_VERIFYSTATUS"が無視される

    • 重要度 - Moderate/Medium

    • curl/libcurlは"OCSP stapling"をサポートしていますが、バグによりvaildationチェックの成功・失敗の有無に限らずvalidationが有効だと判断してしまいます。これにより、ユーザはサーバが正しい証明書を持っていなかったとしてもその判断がつかなくなる可能性が有ります。


主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat Satelliteを使うと管理が便利でしょう。

Red Hat Satelliteを用いた一般的なErattaの適用は、『Red Hat Satellite 6でerrataを適用してみる』を 参考にして下さい。

[参考]

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-2629

セキュリティ系書籍案内

技術評論社より、2/23に『【イラスト図解満載】情報セキュリティの基礎知識』が発刊されます。セキュリティの要素技術がイラスト図解でやさしく解説されており、初心者にもわかりやすくなっていますのでお薦めです。

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

OSSよろず相談室

サイオスOSSよろず相談室(2)

問い合わせボタン