現在位置: ホーム / セキュリティ ブログ / glibcの脆弱性(CVE-2017-8804)

glibcの脆弱性(CVE-2017-8804)

05/08/2017に、05/04/2017に情報が出たrpcbombと同様の、glibcの脆弱性が報告されました(CVE-2017-8804)。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面です。

05/08/2017に、05/04/2017に情報が出たrpcbombと同様の、glibcの脆弱性が報告されました(CVE-2017-8804)。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • CVE-2017-8804
    • strxfrm()のオーバーフロー

    • glibcのxdr_bytes(), xdr_string()でバッファーのデシリアライゼーションに問題が有り、悪意のあるリモートの攻撃者が、細工したUDPパケットを投げることでDoSを引き起こす事が出来る可能性が有ります。これはrpcbombと関係しています。


主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat Satelliteを使うと管理が便利でしょう。

Red Hat Satelliteを用いた一般的なErattaの適用は、『Red Hat Satellite 6でerrataを適用してみる』を 参考にして下さい。

また、アプリケーションやOSの再起動が発生する場合には、pacemakerなどOSSのクラスタ製品LifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

タグ:
OSSよろず相談室

サイオスOSSよろず相談室(2)

問い合わせボタン