現在位置: ホーム / セキュリティ ブログ / GnuTLS の 脆弱性 (GNUTLS-SA-2017-4 : CVE-2017-7507 )

GnuTLS の 脆弱性 (GNUTLS-SA-2017-4 : CVE-2017-7507 )

06/07に、GnuTLSの脆弱性( GNUTLS-SA-2017-4 : CVE-2017-7507 )が公開されました。今回は、この脆弱性の簡単な説明と各ディストリビューションの対応状況をまとめてみます。

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面です。

06/07に、GnuTLSの脆弱性( GNUTLS-SA-2017-4 : CVE-2017-7507 )が公開されました。今回は、この脆弱性の簡単な説明と各ディストリビューションの対応状況をまとめてみます。

 


Priority

Moderate

影響するバージョン

GnuTLS 3.5.12以前のバージョン

修正方法

一次情報源と各ディストリビューションの情報を確認してください。

CVE概要(詳細は一次情報源のサイトをご確認ください)

  • GNUTLS-SA-2017-4 / CVE-2017-7507
    • アプリケーションクラッシュの可能性

    • 重要度 - Moderate

    • TLS Fuzzerにより発見されました。TLS拡張で有効なコンテンツに対してのデコーディング中にNULL Pointer dereferenceを引き起こす可能性が有ります。これにより、GnuTLSを用いたアプリケーションをクラッシュさせることが可能です。


主なディストリビューションの脆弱性情報・アップデート情報

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat Satelliteを使うと管理が便利でしょう。

Red Hat Satelliteを用いた一般的なErattaの適用は、『Red Hat Satellite 6でerrataを適用してみる』を 参考にして下さい。

また、アプリケーションの再起動が発生する場合には、pacemakerなどOSSのクラスタ製品LifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

[参考]

https://gnutls.org/security.html

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

タグ:
OSSよろず相談室

サイオスOSSよろず相談室(2)

問い合わせボタン