現在位置: ホーム / セキュリティ ブログ / Keycloak Node.js adapterの脆弱性( CVE-2017-7474 )

Keycloak Node.js adapterの脆弱性( CVE-2017-7474 )

05/08/2017にKeycloakの脆弱性情報(CVE-2017-7474)が公開されました。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

05/08/2017にKeycloakの脆弱性情報(CVE-2017-7474)が公開されました。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

Important

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7474
    • 認証の迂回の可能性

    • 重要度 - Important

    • Keycloak Node.js adapter 2.5-3.0でトークンを正しく処理していないことが判明しました。これにより、攻撃者が認証を迂回して制限された情報にアクセスできる可能性があります。


主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat Satelliteを使うと管理が便利でしょう。

Red Hat Satelliteを用いた一般的なErattaの適用は、『Red Hat Satellite 6でerrataを適用してみる』を 参考にして下さい。

[参考]

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7474

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

タグ:
OSSよろず相談室

サイオスOSSよろず相談室(2)

問い合わせボタン