現在位置: ホーム / セキュリティ ブログ / MySQL(MariaDB) 5.5/5.6のmysql clientの脆弱性( Riddle : CVE-2017-3305 )

MySQL(MariaDB) 5.5/5.6のmysql clientの脆弱性( Riddle : CVE-2017-3305 )

03/17/2017にMySQL(MariaDB) 5.5/5.6のmysql clientの脆弱性情報( Riddle : CVE-2017-3305 )が公開されました。Riddle(Ridiculous Database Library Exploit)と名付けられて、特設サイトも出来ています。 今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

03/17/2017にMySQL(MariaDB) 5.5/5.6のmysql clientの脆弱性情報( Riddle : CVE-2017-3305 )が公開されました。Riddle(Ridiculous Database Library Exploit)と名付けられて、特設サイトhttp://riddle.link/も出来ています。 今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




Priority

Moderate/Medium

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • CVE-2017-3305
    • MySQL(MariaDB) 5.5/5.6のMySQL Client / MySQL Server間でSSL接続を行っている際の中間者攻撃(Man in the Middle)の可能性

    • 重要度 - Moderate/Medium

    • 以前はMySQL client libraryはMySQL Serverとセキュリティ接続のパラメータがマッチしているかを確認していませんでした。この問題はBACKRONYM脆弱性が2015年に発見されたため、MySQL 5.7できちんと修正されています。当時安定版だったMySQL 5.5.49 と 5.6.30にもセキュリティパッチとして脆弱性が修正されましたが、こちら(5.5/5.6)ではセキュリティパラメータを認証に行うようになっているため、MITM(Man In the Middle: 中間者攻撃)が可能になっています。


主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat Satelliteを使うと管理が便利でしょう。

Red Hat Satelliteを用いた一般的なErattaの適用は、『Red Hat Satellite 6でerrataを適用してみる』を 参考にして下さい。

また、サービスの再起動が発生しますので、pacemakerなどOSSのクラスタ製品LifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

[参考]

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-3305

セキュリティ系書籍案内

技術評論社より、2/23に『【イラスト図解満載】情報セキュリティの基礎知識』が発刊されました。セキュリティの要素技術がイラスト図解でやさしく解説されており、初心者にもわかりやすくなっていますのでお薦めです。

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

OSSよろず相談室

サイオスOSSよろず相談室(2)

問い合わせボタン