現在位置: ホーム / セキュリティ ブログ / QEMUの脆弱性( CVE-2017-2620 ) (Xen: XSA-209)

QEMUの脆弱性( CVE-2017-2620 ) (Xen: XSA-209)

2/21に、QEMUの脆弱性についての情報(CVE-2017-2620)が出ています。PriorityがImportantで、KVMやXenにも関わってきますので、今回は、この脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。 3/1補足: Xen XSA-209 としても出ています。

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面です。

2/21に、QEMUの脆弱性についての情報(CVE-2017-2620)が出ています。PriorityがImportantで、KVMやXenにも関わってきますので、今回は、この脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。

3/1補足: Xen XSA-209 としても出ています。



関連するCVE

CVE-2017-2620

Priority

Important

修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

    CVE-2017-2620

    • 悪意のあるゲストの特権ユーザによるホストのクラッシュやQemu権限での任意のコード実行の可能性

    • 重要度 - Important

    • Cirrus CLGD 54xx VGA エミュレータをサポートするようにビルドしたQEMUは、境界外アクセスの問題が有ります。これはVGAデータをcirrus_bitblt_cputovideoにコピーする際に発生します。これを利用して、悪意のあるゲストOS管理者は、ホストをクラッシュさせたり、Qemuプロセスの権限で任意のコードを実行することが可能になります。


主なディストリビューションの対応方法

virtioや仮想化に関するパッケージのバージョンを更新する必要があります。

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。全てのRed Hat製品でパッチが行き渡っているかを確認するには、Red Hat Satelliteを使うと管理が便利でしょう。

Red Hat Satelliteを用いた一般的なErattaの適用は、『Red Hat Satellite 6でerrataを適用してみる』を参考にして下さい。

また、ホストOSの再起動が発生しますので、pacemakerなどOSSのクラスタ製品LifeKeeperなどの商用のクラスタリング製品を使うとサービス断の時間を最小限にすることが出来ます。

[参考]

CVE-2017-2620 Qemu: display: cirrus: potential arbitrary code execution via cirrus_bitblt_cputovideo

セキュリティ系書籍案内

技術評論社より、2/23に『【イラスト図解満載】情報セキュリティの基礎知識』が発刊されます。セキュリティの要素技術がイラスト図解でやさしく解説されており、初心者にもわかりやすくなっていますのでお薦めです。

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

OSSよろず相談室

サイオスOSSよろず相談室(2)

問い合わせボタン