現在位置: ホーム / セキュリティ ブログ / YARAの脆弱性( CVE-2017-8294 )

YARAの脆弱性( CVE-2017-8294 )

04/27/2017にYARAの脆弱性情報(CVE-2017-8294)が公開されました。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。

こんにちは。SIOS OSSエバンジェリスト/セキュリティ担当の面 和毅です。

04/27/2017にYARAの脆弱性情報(CVE-2017-8294)が公開されました。今回はこの脆弱性の概要と、各ディストリビューションの対応について簡単にまとめてみます。




修正方法

各ディストリビューションの情報を確認してください。

CVE概要(詳細はCVEのサイトをご確認ください)

  • CVE-2017-8294
    • リモートの攻撃者によるDoS(領域外の読み込みとアプリケーションクラッシュ)の可能性

    • YARA 3.5.0での、正規表現コンポーネント中のlibyara/re.cに問題があり、細工されたペイロードでDoS(領域外の読み込みとアプリケーションクラッシュ)を引き起こす可能性があることがわかりました。


主なディストリビューションの対応方法

詳細は、各ディストリビューションの提供元にご確認ください


対処方法

各ディストリビューションの案内に従い、アップデートを行ってください。

[参考]

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-8294

OSSに関するお困りごとは サイオス OSSよろず相談室まで

サイオスOSSよろず相談室 では、OSSを利用する中で発生する問題に対し、長年培ってきた技術力・サポート力をもって企業のOSS活用を強力に支援します。Red Hat Enterprise Linux のほか、CentOS をご利用されている環境でのサポートも提供いたします。

関連コンテンツ
「YARAルール」とClamAV
タグ:
OSSよろず相談室

サイオスOSSよろず相談室(2)

問い合わせボタン